Welcome to GoArmyEd!

Tip of the Day

Ensure that your browser is compatible with GoArmyEd
 
Beginning January 12, 2016, Microsoft will only support technical and security updates for Internet Explorer version 11 or later. What does this mean for GoArmyEd? In order to access and perform processes in GoArmyEd, you will need to use the following browser versions or higher: Internet Explorer 11, Firefox version 38.5.2, or Google Chrome version 47. GoArmyEd will no longer be able to provide technical support for Helpdesk cases which do not meet the minimum browser requirement. Please contact your Information Technology Department or visit the Microsoft, Firefox or Google Chrome support pages for updated assistance.